07/19/2020, 8:21 PM
i am encountering a weird error when calling java code that tries to load a private inner class and java throws a
the call is
Copy code
.addFilter(Query.NumericFilter("price", 0.0, 1000.0))
which is this java code
Copy code
public Query addFilter(Filter f)
and i think the issue is
which is a private inner class i don't know if there is something wrong with my code or the library.. is this supposed to work in java ? if so.. why does it break here ? or why did they write it like that.. if it does not work just asking if its worth raising a issue over or its a thing related to using kotlin or such

Matteo Mirk

07/20/2020, 10:13 AM
What library are you referring to? Could you provide more context?

David Eriksson

07/20/2020, 11:59 AM
Can you make it work in Java and then convert to Kotlin and get an error?


07/20/2020, 9:44 PM
i have not tried it in java only.. the library is JRediSearch here is the issue
and yeah it works in java code.. but not in kotlin, the library fixed it anyways..
is this a error in kotlin? should i raise a issue over this? i am using a eap version.. so maybe i should test with a few more versions..