Ugh, IntelliJ editing performance is absolutely te...
# announcements
Ugh, IntelliJ editing performance is absolutely terrible with Kotlin. 3GB of RAM allocated to IJ and it slows to a crawl with lots of multi-second GC pauses between keystrokes. Are there any workarounds for this or any fixes planned?
I believe intellij 2019.x + kotlin has a bunch of performance regressions that aren't scheduled to be fixed until mid-2020. @Steff Nicolas has been doing a lot of profiling work and driving for this stuff to get fixed, but most of the devs in my org are still using 2018.3 to get around this for now. ­čśú
There is an issue in IJ 2019.3 for Android projects. The Android manifest are scanned during completion. A fix will happen but first on AS 4.1 and we will have to wait for a backport to IJ 2020
My use case is non-Android, unfortunately
But it appears that power-save mode works well enough
for now
I am not aware of any other pure kotlin inspection that slows down IJ completion for kotlin in IJ 2020+. The best would be to profile the IDE and find what operation is running and taking too long.
Help -> Diagnostic has CPU profiling, which saves you having to install a profiler. IntelliJ also automatically outputs dumps when it detects slowness
I reported over a year ago and as far as I can tell it's still not fixed, so performance doesn't seem to be a priority
Power-save mode turns off inspections IIRC so I don't think that's much of a solution
@Steff Nicolas I'll turn off all non-Java/Kotlin extensions & restart without power-save to see if that is it, but I don't run with many extensions, period
Inspections you mean ?
Extensions. I have no custom Kotlin inspections running without power-save mode enabled.
.. although it might be the indexing that is a problem