https://kotlinlang.org logo
#announcements
Title
# announcements
t

Travis Griggs

10/30/2019, 12:45 AM
Is there some trick to getting project wide Unsigned support? I tried:
s

StevieB

10/30/2019, 12:53 AM
I have these two things!
Copy code
"-Xuse-experimental=kotlin.ExperimentalUnsignedTypes",
            "-XXLanguage:+InlineClasses",
I used this a while ago but it seemed to work then!
t

Travis Griggs

10/30/2019, 2:24 AM
I tried that. But to no avail. 😞
However, I notice this at the top of the IDE Preferences>>Other Settings>>Kotlin Compiler where I set that at. I’m not sure where to go in the settings for
app
to get these options to take…
a

Alexey Belkov [JB]

10/30/2019, 9:52 AM
Try this:
Copy code
allprojects {
    tasks.withType(org.jetbrains.kotlin.gradle.tasks.KotlinCompile).all {
        kotlinOptions {
            freeCompilerArgs += [
                    "-Xuse-experimental=kotlin.ExperimentalUnsignedTypes",
                    "-XXLanguage:+InlineClasses"
            ]
        }
    }
}
s

StevieB

10/30/2019, 12:05 PM
Also, wherever you put it, the one in your screenshot seems to be missing "use-" at the start of the option name!
t

Travis Griggs

10/30/2019, 1:25 PM
Modifying the gradle file worked. Using the IDE did not. Even with the spelling correction. Thank you guys!
2 Views