https://kotlinlang.org logo
#announcements
Title
# announcements
s

StevieB

07/09/2019, 6:44 PM
I have a question for the assembled wisdom here (probably in the wrong channel, please correct me). I have been playing around with kotlin, jlink, javafx, tornadofx and JDK 11 and I am pleasantly surprised how well its working (at the basic level anyway). BUT when I try to use a recent kotlin release (1.3.41) I have a problem which seems odd, somewhere in the jlinking process it generates a big module-info.java file which attempts to export kotlin.native.concurrent, it balks at this, apparently because native is a java reserved word!! That package isn't in 1.3.10 which works. Does anyone have any advice on how to surmount this problem? I've tried to find a way of excluding it, but I haven't found that and anyway I don't think that's the correct thing to do.
i

ilya.gorbunov

07/09/2019, 7:00 PM
You can refer to this example of using jlink with Kotlin: https://github.com/ilya-g/kotlin-jlink-examples
s

StevieB

07/09/2019, 8:33 PM
Thank you @ilya.gorbunov 👍🏻
h

Hanno

07/10/2019, 2:54 PM
Uhhh, i ran into this as well some weeks ago
I think it has something to do with automatic modules, where all packages are exported, containing this native thingy package
I did not find a way to exclude the package, seems to be a limitation of the jlink plugin