Do you think it's ok in this case?
# announcements
l
Do you think it's ok in this case?
a
Personally I went the other way and started
PascalCasing
my enums instead
l
interesting
very interesting actually xD
a
also other public `val`s for the same reason; when you put them next to `object`s and sealed classes, as you've found, there doesn't seem to be much reason to leak the implementation details in the naming convention
it still seems kind of contentious when it comes to things like
MAX_VALUE
-type things that can be declared with
const val
and the official kotlin style guide is kind of vague on this
it permits both styles but it's not something so prescriptive that you could use linters to settle debates
k
Same here, PascalCase for most enums.
l
That's very interesting
linters complain about pascal case too, tho
k
Just turn that off, we're not here to serve the linter!
l
I know hahaha
I just wanted to know if it was a bad thing