i’d write that: ``` interface Database { fun ...
# announcements
n
i’d write that:
Copy code
interface Database {
    fun getFoo(): String
}

class MutableDatabase(internal var foo: String) : Database {
    override fun getFoo() = foo
}

class ImmutableDatabase(internal val foo: String) : Database {
    override fun getFoo() = foo
}
g
Interesting - thanks!
n
i’m far from sure this the most “kotlinesque” way perhaps you should ask for more viewpoints and decide which one suits you best