just changes their ugly `return Unit.INSTANCE;` to...
# announcements
k
just changes their ugly
return Unit.INSTANCE;
to the slightly less ugly
return null;
c
converting it to
Consumer<A>
would probably be even better.
k
agreed but that brings up concerns for interop. There'd also have to be 23
ConsumerN<T1,..,T(N-1)>
variants