I have a project where upgrading to Kotlin 1.1.2 (...
# announcements
I have a project where upgrading to Kotlin 1.1.2 (from 1.1.1) causes Travis CI to fail with "Failed to apply plugin [id 'kotlin']". It builds fine on my own machine. builds: https://travis-ci.org/xenomachina/xenocom/builds source: https://github.com/xenomachina/xenocom Is anyone else seeing something like this?
xenomachina: There was no breaking changes from the Kotlin plugin side between 1.1.1 and 1.1.2 regarding Gradle API & version, so it looks weird for now.
I haven't found anything more relevant. Needs a closer look and probably more data.
Clear the cache in travis
👍 1
Apparently the .gradle directory can get bugged when updating
I think I saw someone mention this the other day as well.
@nesl247 Good idea, but it still fails on those builds if I clear the cache.
Oh, for one, you don’t have the right version of java
You need 1.8 with 1.1.2
👍 2
The Kotlin compiler now requires JDK 8 to run. You shouldn't notice any changes, because most other Java development tools such as Gradle and the Android toolchain also require JDK 8, so you almost certainly already have it installed. For code generated by the compiler, Java 1.6 compatibility is still the default, and we have no plans to drop support for generating Java 1.6 compatible bytecode.
@nesl247 Thanks! I hadn't noticed I was using JDK8. I'm pretty new to Travis CI. I'll update that.
Yes! The old JDK was the issue. Thank you!
has some nice stuffs..was looking something similar in kotlin..thanks
recently came across this one - https://appliedgo.net/tui//?src=t ..written in go. Would love to have something like in kotlin too.
@suresh Thanks. I should probably document it better. For now, it's mainly stuff I needed for kotlin-argparser that I thought might be useful in other projects independent of argument parsing. kotlin-argparser uses it for formatting