https://kotlinlang.org logo
#announcements
Title
# announcements
k

kevinrob

04/20/2017, 9:54 AM
@ilya.chernikov here you are! With this log I think that it is linked to low memory? 😕
i

ilya.chernikov

04/20/2017, 10:02 AM
I actually see no signs of OOM here. Do you see anything?
k

kevinrob

04/20/2017, 10:03 AM
094640.870 [DEBUG] [org.gradle.launcher.daemon.server.health.LowMemoryDaemonExpirationStrategy] Received memory status update: {Total: 63321337856, Free: 56795885568}
i

ilya.chernikov

04/20/2017, 10:03 AM
And if you’re still at the same state, could you please look at the output of
Copy code
find $TMPDIR -name "kotlin-daemon.*.log" -exec ls -1rt "{}" + | tail -1
and if it corresponds to the same time period, send it here as well.
I think that
LowMemoryDaemonExpirationStrategy
is just a class in gradle controlling memory stuff. The numbers look ok for me.
k

kevinrob

04/20/2017, 10:05 AM
I can re-run build with SSH for debugging (Circle CI doesn't allow SSH if not enable before)
i

ilya.chernikov

04/20/2017, 10:21 AM
Yes, that would be helpful, I think.
And btw, what versions of gradle and kotlin you’re using there?
k

kevinrob

04/20/2017, 10:23 AM
buildscript.groovy
i

ilya.chernikov

04/20/2017, 10:27 AM
Ah, yes, sorry, I’ve overlooked that one.
😊 1
So far I cannot see anything that points to the problem. There is a chance that it has something to do with the kotlin daemon. To check that it would be nice to see the daemon log (from
find $TMPDIR ...
command above). And of course try to disable daemon by setting
kotlin.compiler.execution.strategy
prop. You can also try to run the gradle with
—no-daemon
switch to get a better reporting (since according to the log you’ve sent, the gradle daemon is crashed.)
k

kevinrob

04/20/2017, 10:32 AM
Okay, I will try
2017-04-20 101857.484 [daemon] INFO: Kotlin compiler daemon version 1.1.2-eap-73 2017-04-20 101857.502 [daemon] INFO: daemon JVM args: -Djava.awt.headless=true -Djava.rmi.server.hostname=127.0.0.1 -Xmx2048m -XX:MaxPermSize=2048m -Dkotlin.environment.keepalive 2017-04-20 101857.502 [daemon] INFO: daemon args: --daemon-runFilesPath /root/.kotlin/daemon --daemon-autoshutdownIdleSeconds=7200 --daemon-verbose --daemon-compilerClasspath /root/.gradle/caches/modules-2/files-2.1/org.jetbrains.kotlin/kotlin-compiler-embeddable/1.1.2-eap-73/6a6e33c32aa077f5d93310951d346231f5d3b515/kotlin-compiler-embeddable-1.1.2-eap-73.jar:/usr/lib/jvm/java-8-openjdk-amd64/lib/tools.jar 2017-04-20 101857.535 [daemon] INFO: starting daemon 2017-04-20 101857.693 [daemon] INFO: daemon is listening on port: 17963 2017-04-20 101858.066 [compiler] INFO: leased a new session 1, client alive file: /root/circulate/build/kotlin/sessions/kotlin-compiler-.salive 2017-04-20 101858.349 [daemon] INFO: Message: logging: using Kotlin home directory <no_path> 2017-04-20 101858.361 [daemon] INFO: Message: logging: configuring the compilation environment 2017-04-20 101926.097 [daemon] INFO: Message: output: output: [...] Removed class names [...] 2017-04-20 101935.822 [compiler] INFO: Done with result 0 2017-04-20 102119.539 [compiler] INFO: leased a new session 2, client alive file: /root/circulate/build/kotlin/sessions/kotlin-compiler-.salive 2017-04-20 102119.619 [daemon] INFO: Message: logging: using Kotlin home directory <no_path> 2017-04-20 102119.628 [daemon] INFO: Message: logging: configuring the compilation environment
This is the log from
/tmp/kotlin-daemon.2017-04-20.10-18-57-457.00.log
i

ilya.chernikov

04/20/2017, 10:34 AM
That one looks ok.
k

kevinrob

04/20/2017, 10:34 AM
It's the log from a failed build 😕
ho, just a thing, I have gradle called multiple times
./gradlew assembleBeta ./gradlew testRelease -Pnocruncher=true --debug Only the second one crash
i

ilya.chernikov

04/20/2017, 10:37 AM
Try the second with
—no-daemon
and
kotlin.compiler.execution.strategy=in-process
. Hopefully it will report problems right to the console.
👍 1
k

kevinrob

04/20/2017, 10:43 AM
With
./gradlew testRelease -Pnocruncher=true --debug --no-daemon -Dkotlin.compiler.execution.strategy=in-process
i

ilya.chernikov

04/20/2017, 10:50 AM
Well, seems that those have no effect. Setting sys opts on
gradlew
call has usually no effect on gradle daemon the wrapper runs. GRADLE_OPS env var should work though. And —no-daemon has no useful effect on the gradle > 3.x, I guess - it runs the gradle daemon anyway.
Is this machine memory constrained somehow? I guess the sudden OOM may result in such a crash. In this case you probably need to reduce Xmx for the gradle daemon (and in a result for a kotlin daemon as well).
k

kevinrob

04/20/2017, 11:00 AM
Okay, I will try, thank for your help
I don't find anything that's work... I don't have any time for that... Thank for your time!
7 Views