https://kotlinlang.org logo
#ktor
Title
# ktor
h

Helio

07/03/2021, 6:54 AM
Hello all, I noticed that after upgrading to Ktor 1.6.1 I had to replace
embeddedServer(Netty, 8080, module = Application::module).start()
with
developmentMode = false
to be able to run my application locally. Is that expected? I couldn’t find any information in the change logs.
Copy code
val builder = ApplicationEngineEnvironmentBuilder()
    builder.module(Application::module)
    embeddedServer(Netty, builder.build {
        developmentMode = false
        connector {
            port = 8080
        }
    }).start()
The reason I had to do it, was to avoid the a similar error reported here. https://youtrack.jetbrains.com/issue/KTOR-2306
a

Aleksei Tirman [JB]

07/05/2021, 9:22 AM
I cannot reproduce your problem. As I can see the
developmentMode
is disabled by default in Ktor 1.6.0 and 1.6.1. Could you please share a code snippet that works unexpectedly with Ktor 1.6.1?
h

Helio

07/05/2021, 11:01 PM
Hello Aleksei, Thanks for getting back. I will try to push a snippet of the problem to github and will make sure to share it with you.
Hello Aleksei, apologies for that… But I found what the problem was. There was a VM option configured in IntelliJ Idea setting
developmentMode true
. Once I removed it Everything worked as expected. My bad!
3 Views