https://kotlinlang.org logo
#ktor
Title
# ktor
n

n8ebel

12/23/2020, 9:06 PM
Has anyone tried enabling/disabling the new 1.5 development mode when running from the command line via the gradle wrapper? I’ve successfully done it via the
application.conf
file by setting
development=true
. And by adding
-Dio.ktor.development=true
to VM options in the IntelliJ run configuration But no luck from the command line so far.
d

duuusha

01/21/2021, 7:44 AM
hi, you can try to assign this option to the
applicationDefaultJvmArgs
property in the Gradle file:
Copy code
application {
    mainClassName = "io.ktor.server.netty.EngineMain"
    applicationDefaultJvmArgs = listOf("-Dio.ktor.development=true")
}
3 Views