https://kotlinlang.org logo
#ktor
Title
# ktor
g

gbaldeck

11/14/2020, 11:29 PM
I have a multiplatform project setup with ktor and I am having issues with running it through intellij. I set some jvm args in the application block of build.gradle.kts to fix errors I was getting, but IntelliJ completely ignores them. I also tried putting them in the gradle run configuration itself and it ignores those too. I've tried rebuilding, remaking the intellij project, invalidating the intellij caches, but nothing works. When I run
gradlew run
it sees the jvm args and starts just fine, it's only through intellij that theres a problem. Does anyone know how to fix this issue?
n

Nikky

11/15/2020, 11:37 AM
never used those default args before.. i can reproduce it on a
kotlin("jvm")
project too (spring server) my guess is that idea just always passes the arguments into the gradle task, when it is empty that overrides the defaults setting arguments in JavaExec tasks might work either way this seems like a bug in idea
i also figured out how you can fix it "temporarily" when you edit the configuration and store it as project fiel you can then edit the xml manually delete the section
<option name="vmOptions" value="" />
and do that every time you accidentally edit the configuration via the UI
in the past i think i tried out jvmDefaultArgs and because it did not seem to work i forgot about it and never used them again.. i did not consider a idea bug at that time.. duh
g

gbaldeck

11/15/2020, 5:40 PM
thanks for the help, I tried that and it is still ignoring them. i filed a bug in youtrack