Is this more likely to be an issue with the genera...
# ktor
Is this more likely to be an issue with the generator or my version of Intellij v2018.2.5?
I’ve already figured it out by adding
Copy code
kotlin.experimental.coroutines = ‘enable’
to the gradle config. However the error-tooltip should be more informative imho.
Looks like you have improper versions somewhere
It should be no
in Kotlin 1.3
☝️ 1
// cc @Deactivated User "Open the pre-configured generator form" link doesn't work for me
Yeah I may have messed up the project config in some way. I’ve run the generator again, and now it looks fine codewise without errors.
@cy It works for me. Though now showing all the content (build button) or scroll bars. Scrolling works but it is not intuitive. In your case doesn’t happen anything when clicking the link? If that’s the case, which browser/version are you using? (I’m trying with Chrome 70) EDIT: Tried safari and works, but tried firefox and shows
[object Object]
in the address. So yeah, it seems that firefox doesn’t like the inlined js like that. So I’ll change it.
work for me too, also chrome 70 and apart from the odd scrolling it generally works nice.
The only feature I wish for, would be to more easily find out which configuration options/modules are checked. Currently the user has to scroll through the rather long list very carefully to find out.
Uhm. I see. Actually I added the pre-configured version later, so didn’t think about it. Would moving the pre-selected features at the top work for you? Or a selected checkbox to show only the selected ones
Both options would do the trick for me. 🙂
👌 1
All done: fixed the firefox issue, the scroll issue and added a checkbox to show marked dependencies only
🙏 1
Thanks @Deactivated User for this amazingly fast fix. The widget works just great now.👍🙂