https://kotlinlang.org logo
#intellij
Title
# intellij
r

ribesg

04/28/2022, 2:57 PM
I really do not expect IntelliJ to recommend & autocomplete with the second option here
r

Rob Elliot

04/28/2022, 3:06 PM
What's wrong?
r

ribesg

04/28/2022, 3:07 PM
Well it should just select the first option, not the second
r

Rob Elliot

04/28/2022, 3:08 PM
For me the first option is the one I get if I just press enter
So I don't see the issue?
r

ribesg

04/28/2022, 3:08 PM
Not for me. IntelliJ tries to be smart
I probably used
isNotEmpty
one or more times recently and so it thinks that’s what I’ll want to use
r

Rob Elliot

04/28/2022, 3:11 PM
I don't recall IntelliJ ever defaulting to anything other than the first option for me
r

ribesg

04/28/2022, 3:13 PM
No it selects the option where the background is little more clear, in my first screenshot it’s the second one. See here, it selects
error(…)
if I autocomplete
r

Rob Elliot

04/28/2022, 3:15 PM
Turn off "sort by name" in the menu in the bottom left of the select
Perhaps that isn't it... I can replicate by typing
isN
, hitting CTL-SPACE, deleting the
N
and adding an
E
. But if go back to the start, type
isE
and hit CTL-SPACE I get
isEmpty
highlighted as expected.
w

wasyl

04/28/2022, 3:23 PM
You can try turning off
Machine Learning Code Completion
plugin, perhaps, if you have it enabled?
3 Views