https://kotlinlang.org logo
#intellij
Title
# intellij
n

napperley

04/24/2021, 4:28 AM
Noticed something weird going on with IntelliJ. The IDE isn't recognising the common module even though I have done a Gradle refresh, and even tried reopening the project.
o

okarm

04/24/2021, 10:20 AM
That sometimes happens. It usually takes several full cache invalidations, rebuilds and Gradle reimports in a row to fix (in no particular order or number of repetitions). Cause is unknown to me and the actual fix is unknown to me as well - I just reload the project until it fixes itself.
n

napperley

04/24/2021, 10:44 PM
I must admit that I switched the project over from Maven Local to Maven Central (as the primary repository) which might have triggered the issue.
There might be a possible fix, however I can't find the Action (something to do with invalidating the Gradle cache) in IntelliJ. I wonder if the Action has been renamed to something else.
Tried the Invalidate Caches Action, unfortunately it doesn't resolve the issue.
Issue is much worse than I thought. Compiler checking is broken in the common module, the expect/actual features aren't working, and there are some compiler checking issues with the other modules (related to expect/actual). As an example IntelliJ is reporting an error that doesn't exist like the following:
Copy code
Actual object `Controller` has no corresponding expected declaration
a

Alexey Belkov [JB]

04/26/2021, 8:20 AM
Can you please file a bug report to http://kotl.in/issue with a sample project to reproduce.