Kris Wong

08/31/2020, 3:56 PM
I can't seem to figure out how to specify the Java version for gradle tasks run in IDEA. I've tried the choose runtime plugin, the module settings dialog, and setting
in, and none have worked. running my task from the command line works with the latter.
Now I have also tried Preferences > Build... > Android > Android Project Structure > JDK Location. however, whatever value I enter into the field is not saved.

Dmitry Kandalov

09/01/2020, 11:34 AM
Preferences > Build, Execution, Deployment > Build Tools > Gradle > Gradle JVM

Kris Wong

09/01/2020, 12:36 PM
oh lord, so many JVM options. will try this one. thanks!
confirmed this works