https://kotlinlang.org logo
#intellij
Title
# intellij
b

bod

07/30/2020, 3:00 PM
Hello, World! I quite often unwillingly trigger some kind of Column Selection Mode, when typing some combination of alt and down arrow. But the only shortcut I see for CSM is alt shift 8, so I don't get it. Any idea of what it could be?
w

wasyl

07/30/2020, 3:10 PM
Perhaps you’re triggering
Clone Caret [Above|Below]
option? Not sure what’s the default shortcut for it (if any)
b

bod

07/30/2020, 3:11 PM
it looks like there's no shortcut for it on my setup
w

wasyl

07/30/2020, 3:29 PM
So what’s exactly the issue, how does it look like? There’s three more things I know of: - selecting with mouse cursor but pressing middle button instead of left, triggers CSM - selecting text using left mouse button but with left alt pressed triggers CSM - pressing alt twice (hold second time) and pressing up/down arrows triggers caret cloning mode
b

bod

07/30/2020, 3:31 PM
that's it!!!!!!! The third one! Good catch!. Do you know if there's a way to disable it?
w

wasyl

07/30/2020, 3:34 PM
I recall chasing it for quite some time myself back when I started using IJ 🙂 I don’t know if there’s a way to disable it, I think I just stopped pressing alt twice 🤔
Actually there is:
👏 1
b

bod

07/30/2020, 3:35 PM
wooooow! Thank you so much!
👍 1
this thing has been bothering me for ... years (I kid you not)
never could understand how I was triggering it
w

wasyl

07/30/2020, 3:36 PM
It is pretty obscure, doesn’t even show up in presentation assistant
b

bod

07/30/2020, 3:37 PM
indeed!
p

poohbar

07/30/2020, 7:25 PM
@bod I have never ever triggered this by accident. I am just wondering, what are you doing when you accidently trigger this?
b

bod

07/30/2020, 7:55 PM
The thing is I've set alt cmd down to "select word" and I do it all the time (find it handy). So inevitably I guess I press alt twice without realizing