Damn, somehow I broke my Intellij 2019.1.3 Communi...
# intellij
Damn, somehow I broke my Intellij 2019.1.3 Community on macOS today. On every project(example: https://github.com/msink/kotlin-libui) I tried to compile it gives me errors like this:
Copy code
* Source files: control.kt, disposable.kt, base.kt, image.kt, paint.kt, text.kt, drawarea.kt, layouts.kt, libui.kt, table.kt, utils.kt, widgets.kt, window.kt
 * Compiler version info: Konan: 1.2.1 / Kotlin: 1.3.31
 * Output kind: LIBRARY

e: org.jetbrains.kotlin.util.KotlinFrontEndException: Front-end Internal error: Failed to analyze declaration Color
Cause: Protocol message tag had invalid wire type.
File being compiled at position: (11,5) in /Users/simon/projects/kotlin-libui/libui/src/nativeMain/kotlin/draw/base.kt
The root cause was thrown at: InvalidProtocolBufferException.java:99
The compiling worked fine before. Uninstalled Intellij, cleared the cradle cache and the following folders: ~/Library/Application Support/IntelliJIdea2019.1 ~/Library/Caches/IntelliJIdea2019.1 ~/Library/Preferences/IntelliJIdea2019.1 Does anyone have a clue what’s happening? Update: After deleting ~/.konan folder and gradle sync everything works again!! 🎉 😅
I think it started after I accidentally applied a quick fix in one of my source files with ‘alt option + enter’
Hm I get the same error when I try to compile the project with Android Studio