https://kotlinlang.org logo
#android
Title
# android
a

allan.conda

06/12/2020, 4:51 AM
anyone know how to fix this warning?
Copy code
/.gradle/caches/transforms-2/files-2.1/08b4d730ba6c80c87328a0558e314dae/jetified-kotlin-stdlib-jdk7-1.3.72.jar: Runtime JAR file has version 1.3 which is older than required for API version 1.4
I can’t find which dependency is using 1.4
j

Joost Klitsie

06/12/2020, 7:14 AM
Maybe you can try to clear your cache? Or just remove that folder?
a

allan.conda

06/12/2020, 1:39 PM
yeah, it just makes another cache and same warning
i

Ivann Ruiz

06/15/2020, 4:09 PM
You could downgrade to
1.3.72
,
1.4
is still not stable, I think
a

allan.conda

06/15/2020, 4:23 PM
But I’m not using 1.4 😞
l

louiscad

06/15/2020, 5:06 PM
I can’t find which dependency is using 1.4
Did you try running
./gradlew :module-you-suspect-has-adependency-on-kotlin-one-point-four:dependencies
starting from the module shaving dependencies yu updated after Kotlin 1.4-M1 was released?
a

allan.conda

06/15/2020, 5:30 PM
Yes, there’s no mention of 1.4 sadly. Only like this:
Copy code
+--- org.jetbrains.kotlinx:kotlinx-coroutines-test:1.3.7
|    +--- org.jetbrains.kotlin:kotlin-stdlib:1.3.71 -> 1.3.72 (*)
|    +--- org.jetbrains.kotlinx:kotlinx-coroutines-core:1.3.7
|    |    +--- org.jetbrains.kotlin:kotlin-stdlib:1.3.71 -> 1.3.72 (*)
|    |    \--- org.jetbrains.kotlin:kotlin-stdlib-common:1.3.71 -> 1.3.72
That would be weird if I’m the only one facing this issue 🤔
l

louiscad

06/15/2020, 5:30 PM
@allan.conda This is the only module you have in your project?
a

allan.conda

06/15/2020, 5:50 PM
No, it’s a multi-modular project using compose and Android Studio Preview. I guess I should try reverting to find the cause..
l

louiscad

06/15/2020, 8:23 PM
Might be related to the use of Compose. DId you double check that configuration that changes the Kotlin version?
a

allan.conda

06/17/2020, 12:01 PM
/.gradle/caches/transforms-2/files-2.1/08b4d730ba6c80c87328a0558e314dae/jetified-kotlin-stdlib-jdk7-1.3.72.jar: Runtime JAR file has version 1.3 which is older than required for API version 1.4
Looks like it was caused by the latest update. Shows up when I update to agp 4.2.0-alpha01 and gradle 6.5-rc-1.
also getting kotlin plugin version unsupported warning…
12 Views