https://kotlinlang.org logo
#android
Title
# android
n

nitrog42

08/02/2018, 8:19 AM
AS 3.3 canary users, is there a way to upgrade the plugin to 1.2.60 ?
j

jishindev

08/02/2018, 8:20 AM
Got a pop up for it a while ago on Android Studio to do just that.
n

nitrog42

08/02/2018, 8:22 AM
but it doesn’t work, it keeps 1.2.50 plugins after restart
g

gildor

08/02/2018, 8:23 AM
n

nitrog42

08/02/2018, 8:23 AM
did it worked for you ?
are you on AS 3.3 or 3.2 ?
g

gildor

08/02/2018, 8:24 AM
I’m on 3.2
n

nitrog42

08/02/2018, 8:24 AM
that’s why
on 3.3 upgrading plugins has been disabled ( Android Studio 3.3 Canary 1 includes Kotlin 1.2.50. The ability to update the Kotlin plugin in Android Studio is temporarily disabled; this is to prevent the installation of incompatible plugins while we resolve some issues.)
g

gildor

08/02/2018, 8:25 AM
Try to install plugin manually using Stable 1.2.60 for AS 3.3: 1.2.60-release-Studio3.3-1
Sometimes it’s happening because you had a plugin, than update IDE, but old plugin doesn’t compatible with new version of IDE
n

nitrog42

08/02/2018, 8:26 AM
yes but that’s different, they disabled it to avoid this kinda of issue
but still release 3.3 plugins versions
I tried installing local with the zip
nope still not working ^^
either there is an hidden flag on the 3.3 version, or we’ll need to wait for canary 4 or more
a

alex2069

08/02/2018, 8:36 AM
I'm on 1.3-M1 plugin
3.3 Canary 3
It auto-updated to it
n

nitrog42

08/02/2018, 8:43 AM
weird, 1.3 M1 plugin seems to be for AS 3.2, not 3.3
2 Views