I can’t seem to disable Kotlin incremental compila...
# android
I can’t seem to disable Kotlin incremental compilation on a Gradle build. I’m using
and `com.android.tools.buildG3.0.0-alpha4`:
Copy code
./gradlew -Pkotlin.incremental=false clean assembleRelease
./gradlew -Pkotlin.incremental=false assembleRelease // Prints "Using kotlin incremental compilation"
My goal is to disable it for CI builds, preferably without having to configure the CI environment globally by using special
@btilbrook-nextfaze: have you fixed this?
You could edit your CI script to first run
? IIRC travis starts you with a clean build dir, if you're using that
That’s what I’ve resorted to so far. But I don’t need all of the workspace to be cleaned, I just want to disable Kotlin incremental. The Gradle properties don’t seem to work, though, according to the log output at least.