Erik
09/02/2021, 3:31 PMOrNull
variant. Or in the coroutines lib, it's conventional to either write a suspend fun foo()
or write a non-suspending extension fun CoroutineScope.foo()
, but not suspend fun CoroutineScope.foo()
. And likewise, suspend fun foo(): Flow<Bar>
usually doesn't make sense, but fun foo(): Flow<Bar>
is more conventional.
It's probably a good idea to use the same naming conventions in your own Kotlin APIs.CLOVIS
09/03/2021, 6:54 AM.sort
and .sorted
.Erik
09/03/2021, 7:20 AMJacob
09/03/2021, 6:05 PMsuspend fun CoroutineScope.foo()
. is about more than a naming convention.