Thread
#stdlib
    mbonnin

    mbonnin

    1 year ago
    What could go wrong if I'm using
    kotlin-stdlib:1.4.32
    and
    kotlin-reflect:1.3.72
    ? The compiler tells me strange errors could happen but that doesn't sound very specific. Should I care?
    ilya.gorbunov

    ilya.gorbunov

    1 year ago
    They are developed together, so they can be interdependent on each other, that's why it's recommended to use versions that are at least have the same major part, e.g. "1.4.x"
    mbonnin

    mbonnin

    1 year ago
    Is there an instance of such a problem documented somewhere?
    Reason I'm asking this is that it looks like I've been running this configuration for a while and nothing bad happened 🤞. On the other hand, the warning does create some noise like https://youtrack.jetbrains.com/issue/KT-38145. My fear is that people (myself included) get accustomed to the warning so that when the "strange error" happens, they have forgotten about it and in the end, no warning at all would have had the same result without the initial questionning
    Adam Powell

    Adam Powell

    1 year ago
    I've seen crashes happen as a result of this. No reason to run with scissors here. 🙂
    mbonnin

    mbonnin

    1 year ago
    It could also be like "run with an helmet". The helmet will save your life if you fall on a curb. But in the vast majority of the cases it will take you time to put your helmet on and you might run slower (having to track the dependencies manually, understand the message and in some cases why Gradle plugins have multiple versions of the stdlib in the classpath, etc...)
    Definitely not wanting to die on this hill though, I was just trying to get a feeling of how often I could expect to hit the curb 😅
    Also if I could hit the curb often, it feels like mandating the helmet could be a good thing. The in-between wording here doesn't feel like I'm doing an informed decision
    In all cases, I'll have my helmet on for next time, all warnings gone 🙂