We have `emltyList()` (…Set/Map) top-level functio...
# language-proposals
i
We have
emltyList()
(…Set/Map) top-level functions, and I wonder shouldn’t there be an equivalent like
emptyMutableList()
?
👍 1
b
I agree with this idea. Even if it's just a
inline fun <T> emptyMutableList() = mutableListOf<T>()
, it would be better for consistency and readability.
r
How is that any more readable than just
mutableListOf()
without any arguments?
b
Read it in English. "Let the variable 'x' be a mutable list of". What's in that list? It's unclear. Could be anything
r
I thought the point is that nothing is in that list? That seems pretty clear to me.