# exposed

Valentin Rouault

10/26/2018, 4:58 PM
I now switched to use the DAO for interaction with TornadoFX, because it seems to work while writing. But when I execute the program, I get an IAE: Parameter specified as non-null is null: method, parameter id. But in the docs there is nothing in the examples about having to use an Id apart from the definition of the class. And in the line above I access the database table with the DSL and there it works, so the database isn't empty.
Copy code
println("DSL: ${Kreuzungen.selectAll().toList().get(0)}")
println("Element 1: ${Kreuzung.all().toList().get(0)}")
Kreuzungen in this case is the table definition and Kreuzung is the entity class.
Also wrapping a DSL Query gave the same result. And counting the Objects in the query gave the expected number, I have the feeling that is stops working after "toList()"


10/27/2018, 8:53 AM
What is the table definition? Are you sure that you properly define nullable columns?

Valentin Rouault

10/27/2018, 1:44 PM
Oh 😅 I had defined another Index in the table, so that it's easier to understand what exactly you're joining. Now I removed it and it worked! I didn't really thought about it, because there is also an additional ID in the examples, but I think, the error was that my ID Column was a primary key, the autogenerated too and so it couldn't be generated. But the one in the example is a unique index and not a key. Thanks for giving me the hint!