Hi, I’m trying to upgrade to the newest dokka plug...
# dokka
Hi, I’m trying to upgrade to the newest dokka plugin from 0.10.1 and in both single and multi-module modes the plugin always says
Exiting Generation: Nothing to document
. I’m obviously missing something but it’s unclear to me what it is. I’m not using any kind of unusual source code layout. It’s a multi-module project with each module having code in
. I’ve tried the single module mode (customizing
and running
./gradlew dokkaHtml
) and multi-module mode (customizing
and running
./gradlew dokkaHtmlMultiModule
) but get the same result either way. Ideally I want to eventually be able to generate -javadoc.jar files, and probably use the Jekyll support to generate an all-in-one page to push to the project’s website, but I’m stuck with getting the plugin to find the code at all. https://github.com/robfletcher/strikt/
After a quick glance i am not sure what is the problem, but i’ll try to debug it tomorrow ☺️
The only weird thing I’m doing is using a
plugin which is what applies dokka to the sub-projects, but there seems to be no issue with the plugin getting applied
The reason why it is not working is dokka doesn’t get any configuration. We had an issue like this: https://github.com/Kotlin/dokka/issues/1463
Ah so it is because I’m using a buildSrc plugin. Interesting. Thanks for looking into it.
Thanks. I got it working by changing my
plugin to an