``` dokkaHtml { outputDirectory.set(ne...
# dokka
l
Copy code
dokkaHtml {

        outputDirectory.set(new File(buildDir, "docs/htmldocs"))

        dokkaSourceSets {
            named("main") {
                includeNonPublic.set(false)
                // Emit warnings about not documented members. Applies globally, also can be overridden by packageOptions
                reportUndocumented.set(true)

                packageOptions {
                    prefix.set("health.waire.sdk.cdetect.internal")
                    // will match health.waire.sdk.cdetect.internal.bluetooth and all sub-packages of it
                    suppress.set(true)
                }
                // Allows to customize documentation generation options on a per-package basis
                // Repeat for multiple packageOptions
                perPackageOption {
                    prefix.set("health.waire.sdk.cdetect.internal") // will match kotlin and all sub-packages of it
                    suppress.set(true)
                }
            }

        }

    }
m
In the latest releases the prefix was changed to be a regex, so if you have sub packages in internal you may want to add
.*
A thing which works in my project is to exclude all internal packages like this:
Copy code
perPackageOption {
   matchingRegex.set(".*\\.internal.*") // will match all .internal packages and sub-packages 
   suppress.set(true)
}
l
@Mike Penz thanks so much! worked a treat. the amount of things I tried ­čą▓ appreciate the help.
­čÄë 1