Thread
#kotlintest
    b

    bbaldino

    3 years ago
    @sam would you be opposed to a PR for hoplite which allowed for comments in json? there's an option in jackson.
    or maybe there's a better idiom to use?
    sam

    sam

    3 years ago
    absolutely that’s a good idea
    no reason why it can’t be turned on
    b

    bbaldino

    3 years ago
    ok
    trying to test and deploy to local but it wants
    signatory.keyId
    , should that be needed just to publish to local maven? sorry, gradle noob.
    sam

    sam

    3 years ago
    do a pull and retry
    b

    bbaldino

    3 years ago
    hm, still the same
    sam

    sam

    3 years ago
    cat the gradle.proeprties file from the repo
    b

    bbaldino

    3 years ago
    i'm just trying to run 'publishToMavenLocal' from hoplite-json directly
    sam

    sam

    3 years ago
    run it from the top level task ?
    b

    bbaldino

    3 years ago
    same
    ~/work/hoplite$ cat gradle.properties
    #these should be overriden if you want to do release
    signing.keyId=xx
    signing.password=xx
    signing.secretKeyRingFile=~/sksamuel.gpg
    
    ossrhUsername=xx
    ossrhPassword=xx
    
    intellijPublishUsername=xx
    intellijPublishPassword=xx
    
    org.gradle.caching=true
    sandbox = .
    sam

    sam

    3 years ago
    ./cat gradle.properties
    oh signatory
    what’s that
    are you using the gradlew ?
    or your own older gradle ?
    b

    bbaldino

    3 years ago
    i was running from intellij
    sam

    sam

    3 years ago
    is that configured to use the gradle from the project (gradlew) or your own install of gradle
    b

    bbaldino

    3 years ago
    i just tried gradlew on the command line and get the same thing looks like:
    ~/work/hoplite$ ./gradlew publishToMavenLocal
    
    Welcome to Gradle 5.2.1!
    
    Here are the highlights of this release:
     - Define sets of dependencies that work together with Java Platform plugin
     - New C++ plugins with dependency management built-in
     - New C++ project types for gradle init
     - Service injection into plugins and project extensions
    
    For more details see <https://docs.gradle.org/5.2.1/release-notes.html>
    
    > Task :hoplite-aws:signMavenJavaPublication FAILED
    
    FAILURE: Build failed with an exception.
    
    * What went wrong:
    A problem was found with the configuration of task ':hoplite-aws:signMavenJavaPublication'.
    > No value has been specified for property 'signatory.keyId'.
    
    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
    
    * Get more help at <https://help.gradle.org>
    sam

    sam

    3 years ago
    add signatory.keyId=xx to the gradle.properties file
    and it will work
    can you PR that too when you do it ?
    b

    bbaldino

    3 years ago
    yeah
    sam

    sam

    3 years ago
    Thank you
    b

    bbaldino

    3 years ago
    now i get
    > Task :hoplite-core:compileKotlin
    w: /Users/bbaldino/work/hoplite/hoplite-core/src/main/kotlin/com/sksamuel/hoplite/preprocessor/PropsPreprocessor.kt: (29, 73): The resulting type of this 'javaClass' call is Class<PropsPreprocessor.Companion> and not Class<PropsPreprocessor>. Please use the more clear '::class.java' syntax to avoid confusion
    sam

    sam

    3 years ago
    that’s just a warning so you can either fix it as part of your PR or ignore it
    b

    bbaldino

    3 years ago
    ah, oops, error was further down
    hm, still complaining about signatory i guess:
    * What went wrong:
    A problem was found with the configuration of task ':hoplite-aws:signMavenJavaPublication'.
    > No value has been specified for property 'signatory.keyId'.
    this is from running
    ./gradlew publishToMavenLocal
    sam

    sam

    3 years ago
    But you added signatory.keyId to gradle.properties ?
    b

    bbaldino

    3 years ago
    yeah
    cat gradle.properties
    #these should be overriden if you want to do release
    signing.keyId=xx
    signatory.keyId=xx
    signing.password=xx
    signing.secretKeyRingFile=~/sksamuel.gpg
    
    ossrhUsername=xx
    ossrhPassword=xx
    
    intellijPublishUsername=xx
    intellijPublishPassword=xx
    
    org.gradle.caching=true
    sandbox = .
    sam

    sam

    3 years ago
    ok gonna try from fresh
    its running
    same thing
    I’ll have to fix tonight, I don’t know what’s causing it
    b

    bbaldino

    3 years ago
    ok
    sam

    sam

    3 years ago
    it’s basically a property that the plugin needs
    and setting dummy values in the gradle.properties usually works
    it shouldn’t need to sign them for local anyway
    b

    bbaldino

    3 years ago
    worked around it by hard-coding
    ext.isReleaseVersion
    to false
    sam

    sam

    3 years ago
    ah ok
    b

    bbaldino

    3 years ago
    i didn't include any of the gradle changes