https://kotlinlang.org logo
#coroutines
Title
# coroutines
z

zak.taccardi

06/18/2021, 3:50 AM
Just to clarify - coroutines now requires Java 8 (with version
1.5.0
of the lib), which means all Android projects that consume it must enable Java 8 desugaring?
e

ephemient

06/18/2021, 7:22 AM
minSdk=26 or higher will work directly. if you must use kotlinx.coroutines on lower android api levels, then yes, you need desugaring
4 Views