dniHze05/22/2021, 4:58 PM
operator? I know that direct replacement for it is
, but I'm still wandering why the team decided to avoid regular
naming for particular operator in a favor of, well, a longer and more self-describing name. For me it's kinda weird trying to name basically the same thing differently, especially from the common to other libraries and languages perspective. Not trying to convince anybody to rename the operator, just searching for the reasoning.
diesieben0705/22/2021, 5:01 PM
is just one of them. RXJS does something similar, it has
, all of which could be called "flatMap".
dniHze05/22/2021, 5:07 PM
. For me the concern is that newcomers just going for
, which is deprecated. And while IDE is a brilliant tool and will teach you in 1 min that the replacement is a
, it's still a confusing thing.
is deprecated, and
is FlowPreview scoped. That should hit hard an unprepared for experimental APIs person.
okarm05/22/2021, 8:52 PM
was never actually used, it only exists so that the IDE can steer people looking for
towards the more explicit naming of
with the replacement quick fix.
@Deprecated( level = DeprecationLevel.ERROR, message = "Flow analogue is 'flatMapConcat'", replaceWith = ReplaceWith("flatMapConcat(mapper)") )
CLOVIS05/23/2021, 8:29 AM
dniHze05/23/2021, 8:49 AM