https://kotlinlang.org logo
#coroutines
Title
# coroutines
v

voddan

10/05/2018, 3:31 PM
I mean, anything is better than a 5-word name that we have now. How about Delegates.fixedPool?
e

elizarov

10/05/2018, 4:29 PM
It is too dangerous function for a short name.
We don’t want to be easily discoverable. It is long on purpose.
👍 1
v

voddan

10/05/2018, 4:41 PM
Yes, but as the slide shows, people treat it as normal API , similar to those in other frameworks
e

elizarov

10/05/2018, 4:42 PM
We’ll see what we can do.
j

jkbbwr

10/05/2018, 6:37 PM
newFixedThreadPoolContext
is super clear what it means, making it anything else removes meaning
6
d

Dico

10/05/2018, 11:02 PM
It could be
Dispatchers.newFixedThreadPool
👍 4
The counter examples aren't much shorter because they have the "namespace" thing, just like
Dispatchers
, making it longer
e

elizarov

10/06/2018, 1:40 PM
👆🏼 1
🤔 1
3 Views