<@U4S7P1QSJ> Conceptually, it is the same. Just a ...
# coroutines
e
@rrva Conceptually, it is the same. Just a different name for the same concept. https://en.wikipedia.org/wiki/Fiber_(computer_science)
r
This does not apply then when comparing the kotlin flavor to quasar? http://www.open-std.org/jtc1/sc22/wg21/docs/papers/2014/n4024.pdf
it’s how c++/boost defined fibers I guess
In short - the difference between coroutines and fibers is, that the context switch between fibers is managed by a scheduler (selects the next fiber ...). Coroutines don’t have a concept of a scheduler.
e
It is the same. The difference some people put into Fibers vs Coroutines are immaginary and is invented by those people who think they are different. E.g., it might be one immaginary difference in C++ and a completely other difference somewhere else. In fact, it is the same concept.
The fact that one async programming proposal in C++ is called “fibers” and the other is called “coroutines” is a pure chance. They could have been called the other way around without truly changing anything.