And last thing. It is better not to use `Async` in...
# coroutines
e
And last thing. It is better not to use
Async
in the name of suspending function. This naming is better to be reserved for functions that start asynchronous operation and return immediately, usually with some kind of future/deferred result. The async part the name serves as a reminder to the invoker of this function that they should not ignore the result, but must await for it or compose it into a larger computation in some way. There is no such risk with suspending functions, and the async in their name is superfluous.
1
👍 1
v
elizarov: this looks like something to be added to the style guidelines