I think 1️⃣ would be the preferred from a domain-modeling standpoint, while the other two only express a generic function intent. In this particular case maybe they won’t be bad since the interface name already conveys the meaning and a function name will probably be redundant. This said and considering Dagger constraint, maybe I’d prefer 2️⃣ for conciseness.
a
arekolek
01/24/2020, 10:07 AM
One issue with 2️⃣ that I see is that you can't look for invocations using "find usages" in IDE