https://kotlinlang.org logo
#squarelibraries
Title
# squarelibraries
r

rachael

11/16/2021, 8:45 PM
Looking at https://github.com/square/okhttp/issues/3251 and https://github.com/square/okhttp/issues/6453, both mention that OkHTTP v5 will include changes to handle corrupted cache states more gracefully. Can you say whether OkHTTP v5 will be backwards compatible for use with Retrofit 2.9.0? We have some clients currently on OkHTTP 4.9.1 running into this issue.
y

yschimke

11/16/2021, 9:58 PM
Yes. Will be API be compatible, it's almost a 4.14 but with specific support for graal and mockwebserver cleanup.
1