Is there a better way to do something like this? ...
# arrow
c
Is there a better way to do something like this?
Copy code
listOf(
{ foo() }
{ bar() }
{ baz() }
).parTraverseEither { it() }
c
i suppose that
.parTraverseEither { it() }
==
.parSequenceEither()
☝️ 1
c
You could also probably use function references?
Copy code
listOf(::foo, ::bar, ::baz)
  .parSequenceEither()
Depending on the exact signature of the functions, that could increase readability
c
Thank you 🙂
I feel like I have a million questions, I really have to thank you guys for being so helpful
👍 1