Thread
#serialization
    n

    Norbi

    1 year ago
    I have upgraded to 1.5.0-RC and I get this error no matter what I try 😦 Stacktrace:
    'void kotlinx.serialization.modules.SerialModuleImpl.<init>(java.util.Map, java.util.Map, java.util.Map, java.util.Map)'
    java.lang.NoSuchMethodError: 'void kotlinx.serialization.modules.SerialModuleImpl.<init>(java.util.Map, java.util.Map, java.util.Map, java.util.Map)'
    at kotlinx.serialization.modules.SerializersModuleKt.<clinit>(SerializersModule.kt:74)
    at kotlinx.serialization.json.Json$Default.<init>(Json.kt:65)
    at kotlinx.serialization.json.Json$Default.<init>(Json.kt)
    at kotlinx.serialization.json.Json.<clinit>(Json.kt)
    at kotlinx.serialization.json.JsonKt.Json$default(Json.kt:130)
    - Kotlin version: 1.5.0
    - kotlinx-serialization version: 1.2.0
    - Kotlin platforms: multiplatform (JVM + JS)
    - Gradle version: 6.8.3
    - IDE version: 2021.1.1 RC
    - Other relevant context: Java 15
    Have you seen anything similar? Thanks.
    Karlo Lozovina

    Karlo Lozovina

    1 year ago
    is your kotlin and plugin.serialization version the same? I have it like this:
    kotlin("jvm") version "1.5.0-RC"
        kotlin("plugin.serialization") version "1.5.0-RC"
    btw, somtimes I'll get weird errors from serialization (not like yours but still), it usually helps to
    gradle clean && gradle build
    from the terminal
    n

    Norbi

    1 year ago
    Thanks for the hints... A transitive dependency of kotlinx-serialization-runtime:0.20.0(!!!!) caused the problem 😕
    Karlo Lozovina

    Karlo Lozovina

    1 year ago
    must've been fun to find that one 😄