dimsuz
04/04/2022, 11:05 AMUnnecessaryParentheses
rule and it reported this code
offset.y.toInt() in item.offset..(item.offset + item.size)
Sure, technically those can be removed, but wouldn't it look less readable? Do you think this might be an exception or config option?
If yes, I can create issue and occasionally a PR.gammax
04/04/2022, 11:13 AMi in 0..(1+2)
// vs
i in 0..1+2
dimsuz
04/04/2022, 11:17 AM(someClass.value.toInt() + otherClass.value) to (size + count)
vs
someClass.value.toInt() + otherClass.value to size + count
I find the latter less readable.ephemient
04/04/2022, 11:19 AMoffset.y.toInt() to item.offset.rangeTo(item.offset + item.size)
(someClass.value.toInt() + otherClass.value).to(size + const)
dimsuz
04/04/2022, 11:21 AMephemient
04/04/2022, 11:31 AMand
and or
having the same precedence, unlike &
and |
in every other language…dimsuz
04/04/2022, 11:53 AMephemient
04/04/2022, 12:01 PMBrais Gabin
04/04/2022, 12:43 PM