Mike Wolfson

    Mike Wolfson

    11 months ago
    Hi folks, I am seeing a weird thing, running
    1.18.1
    but switched to
    1.17..1
    and saw the same thing. I am seeing a weird thing, where when I get my Detekt issues down to 0, the configuration file seems to get ignored... I mean if I have at least 1 error, I will see it, but and as soon as I fix it - so I am down to 0 issues, Detekt seems to ignore my config file (and I see ALL the issues I have carefully Suppressed) My detekt config:
    apply plugin: "io.gitlab.arturbosch.detekt"
    
    detekt {
        toolVersion = detekt_version
        buildUponDefaultConfig = true
        autoCorrect = true
        source = files("$projectDir")
        config = files("$projectDir/analysis/detekt/detekt.yml")
        parallel = true
    
        reports {
            html.enabled = true
            xml.enabled = false
            txt.enabled = false
        }
    }
    Is there some default value I need to set to change this functionality? I feel like this must be something I have configured wrong, since I can see this in
    1.17.1
    and
    1.18.1
    (so it is not likely a bug, or this would be a bigger deal.
    Here is the terminal Output showing good build with at least 1 error, then the next build with ALL the errors back
    Also, I noticed the HTML report shows 0 errors, so it is only Gradle failing.
    Finally, in case this bit of my config file may help...
    build:
      maxIssues: 0
      excludeCorrectable: false
      # weights:
      # complexity: 2
      # LongParameterList: 1
      # style: 1
      # comments: 1
    
    config:
      validation: true
      warningsAsErrors: false
      # when writing own rules with new properties, exclude the property path e.g.: 'my_rule_set,.*>.*>[my_property]'
      excludes: ''
    gammax

    gammax

    11 months ago
    That's the first time I see this kind of behavior. As a sanity check, i can say that the way you're setting
    source
    is suboptimal, as your specifying projectDir which will include also the build folders and more.
    I would either remove the source entirely (and fallback to the default
    src/main/...
    ) Or tweak it a bit
    But that should be unrelated to your issue. Having a reproducer would help a lot
    Mike Wolfson

    Mike Wolfson

    11 months ago
    I will share that in a PM, thanks Nicola