https://kotlinlang.org logo
#mockk
Title
# mockk
c

christophsturm

12/05/2020, 12:41 PM
it seems mockk 1.10.3 does not support jdk 1.8. is that by design?
Copy code
io/mockk/proxy/jvm/dispatcher/JvmMockKDispatcher has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
oh it seems there is a separate release for jdk 1.8. why is that? I don’t really need jdk 1.8 but I run it on ci to make sure my library stays compatible to 1.8
m

Mattia Tommasone

12/06/2020, 9:57 PM
that’s because 1.10.3 was inadvertedly released without jdk8 compatibility v1.10.3-jdk8 is the same release but with jdk8 support moving forward we will have just one release per version with jdk8 compatibility
c

christophsturm

12/08/2020, 11:06 AM
maybe you should release a 1.10.4 version soon. the jdk8 version is not an obvious find when bumping versions. also the gradle versions plugin thinks that 1.10.3 is newer than 1.10.3-jdk8:
Copy code
- io.mockk:mockk [1.10.3-jdk8 -> 1.10.3]
4 Views