h

    Hanno

    2 years ago
    Hey guys, maybe you know Something: is there any news, discussion or whatever regarding the support for bundled ide plugins with compiler plugins, so that the user doesn't need to install ide Support manually?
    Rachel

    Rachel

    2 years ago
    Hi @Hanno Arrow Meta provides a Gradle plugin to use the compiler plugin during the compilation
    y

    Youssef Shoaib [MOD]

    2 years ago
    @Rachel I think he is talking about bundling IntelliJ Idea plugins with Kotlin compiler plugins
    Rachel

    Rachel

    2 years ago
    Thanks for the point @Youssef Shoaib [MOD] Arrow Meta includes a compiler plugin in the IDE plugin to offer their features however that compiler plugin isn't used during compilation. Arrow Meta provides a Gradle plugin to use the compiler plugin during the compilation
    h

    Hanno

    2 years ago
    Thanks for the info, that was the state i expected and already experienced. Does that mean there was no discussion yet about how it could be solved so that a user wouldn't need to install an ide plugin? Or at least gets a notification in the IDE in gradle import for auto download of the corresponding ide plugin so that the versions align etc?
    I have trouble finding the ide plugin for the meta compiler plugin, isn't it deployed somewhere?
    Ah, it's printed in the build log, i see xD
    Incompatible with my intellij version 😦
    y

    Youssef Shoaib [MOD]

    2 years ago
    @Hanno same thing happened to me. The 1.4 version should hopefully fix that. It's currently a WIP, but hopefully it will be out as a snapshot soon