https://kotlinlang.org logo
#compose
Title
# compose
t

Trey

04/16/2022, 3:13 PM
I've run into an issue with compose 1.1.1 and kotlin 1.6.20 not being supported. It appears to be failing on purpose because compose is checking the kotlin version. It recommends 1.6.10 and suggests overriding suppressKotlinVersionCompatibilityCheck, but I can't get that to work because of changes in Android Studio. Has anybody run into this with 1.6.20 and most importantly, do you have a work around?
k

Kirill Grouchnikov

04/16/2022, 3:17 PM
Wait until Compose officially supports 1.6.20
a

Adam Powell

04/16/2022, 3:17 PM
If you're trying to use 1.6.20 use the compiler plugin from here https://androidx.dev/storage/compose-compiler/repository
Or wait for the official release 🙂
t

Trey

04/16/2022, 3:18 PM
Is it common for Compose to not support the latest stable release from kotlin? How long does it typically take for compose to support it?
a

Adam Powell

04/16/2022, 3:19 PM
The above was available the day 1.6.20 went stable
In the past it took much longer but we've had builds for the Kotlin milestone releases and RCs within a few days at most for 1.6.20
Google maven binary updates reflect moving all of androidx/jetpack to the new kotlin version and can trail by a few weeks; that's accelerating as well
t

Trey

04/16/2022, 3:22 PM
Thanks for the info!
👍 1
j

James Black

04/16/2022, 8:06 PM
Do you require Kotlin 1.6.20? I just set the Kotlin version in my gradle.properties and I also use this in build.gradle.
Copy code
org.jetbrains.kotlin:kotlin-gradle-plugin
This is what I did:
Copy code
dependencies {
    classpath("org.jetbrains.kotlin:kotlin-gradle-plugin:${kotlinVersion}")
🚫 1
c

Colton Idle

04/19/2022, 3:43 AM
Heres a compat mapping too if you haven't seen it: https://developer.android.com/jetpack/androidx/releases/compose-kotlin
4 Views