I’ve tried compose 1.1.1 with `compose-compiler:1....
# compose
I’ve tried compose 1.1.1 with
from https://androidx.dev/storage/compose-compiler/repository It seems to work, does anyone know if there can be any specific issues using such kinds of combos (i.e. compiler 1.2.x + rest of compose 1.1.x )? Besides being unsupported of course 🙂
Actually this is supported. If you can build the project with the compiler version, there’s shouldn’t be any problems. If the versions of compiler and runtime aren’t compatible, there will be an error (
You are using an outdated version of Compose Runtime that is not compatible with the version of the Compose Compiler plugin you have installed.
🙏 1
This was also mentioned in the release note of an earlier version.
The Compose Compiler now supports older versions of the Compose Runtime (1.0). Prior to this change, the Compose Compiler was only compatible with the Compose Runtime of the same version or later. After this change, the Compose Compiler is compatible with an older version of the Compose Runtime (1.0).
🙏 1