Thread
#compose
    Namig Tahmazli

    Namig Tahmazli

    1 year ago
    After switching to compose version beta08, updating kotlin version to 1.5.10 I am stuck on the build error which is in 🧵 I compared my setup with Crane sample app so I could not spot specific differences. I also searched on Google. It seams it is general compiler issue so I did not find something useful related to compose. Stack trace and build file snippets in thread. Any help is appreciated 🙇‍♂️
    Vadim

    Vadim

    1 year ago
    Here's related thread with links to filed bugs https://kotlinlang.slack.com/archives/CJLTWPH7S/p1622717694230500
    Namig Tahmazli

    Namig Tahmazli

    1 year ago
    Alright. That’s weird though cause the sample app compiles fine with beta08 and kotlin 1.5.10
    Colton Idle

    Colton Idle

    1 year ago
    May be a long shot, but you can try removing that entire kotlinOptions block. java 8 is the default now, IR is on by default, and that flag (AFAIK) I have never used it/needed it in 5 of my compose projects.
    Ash

    Ash

    1 year ago
    Not sure ... but this fixed us? Wish we had a better answer ...
    Vadim

    Vadim

    1 year ago
    You can follow tickets in the thread linked above to be notified when this will be fixed/released. Also you can downgrade to beta07 I have no idea what this error means but was able to identify the exact code that triggers this error in my project (spent a lot of time on it commenting out almost everything until error disappeared) and refactored it to non-failing version. I think it has something to do with interfaces with generics and classes that implement those interfaces. You can find examples of problem code in those same tickets