Samir Basnet

    Samir Basnet

    1 year ago
    Faced this error after upgrading to beta 04
    java.lang.NoSuchFieldError: No static field Companion of type Landroidx/compose/foundation/layout/BoxScope$Companion; in class Landroidx/compose/foundation/layout/BoxScope; or its superclasses (declaration of 'androidx.compose.foundation.layout.BoxScope' appears in /data/app/com.view9.mahal-Zh5TQ66RD7sgpFKhGyXOyg==/base.apk)
    at com.google.accompanist.pager.Pager.Pager(Pager.kt:461)
    at com.google.accompanist.pager.Pager.HorizontalPager(Pager.kt:147)
    Filip Wiesner

    Filip Wiesner

    1 year ago
    have you upgraded accompanist as well?
    I guess you did if it's
    com.google.accompanist
    🤔 That package name is since version 0.7
    Samir Basnet

    Samir Basnet

    1 year ago
    Oh snap i had only updated accompanist coil and forgot accompanist pager . Thanks
    Filip Wiesner

    Filip Wiesner

    1 year ago
    😄 happens to the best of us
    Samir Basnet

    Samir Basnet

    1 year ago
    Yup can`t avoid that