Thread
#compose
    YASAN

    YASAN

    1 year ago
    I am trying to disable click ripple effect by
    .clickable(indication = null)
    even tho Android Studio autocompletes it, it becomes red instantly and wont build. Any ideas?
    l

    Luke

    1 year ago
    You also have to give
    interactionSource
    YASAN

    YASAN

    1 year ago
    In
    clickable
    or as a normal modifier?
    Once I add both it works but am not sure what I should pass for
    interactionSource
    l

    Luke

    1 year ago
    By default it's
    remember { MutableInteractionSource() }
    , I would go with that
    YASAN

    YASAN

    1 year ago
    Thank you it works!
    Chris Sinco [G]

    Chris Sinco [G]

    1 year ago
    Are you trying to disable the ripple effect on a component that is expected to have it? i.e. Material component
    Or you are building a custom component that should register clicks but you don’t want the ripple presentation?
    I ask since we intentionally have ripple when
    clickable
    is used in order to give users/developers consistent visual feedback from touch out-of-the-box.
    YASAN

    YASAN

    1 year ago
    Yeah I know its needed, but I had seen comments about it causing performance issues on Compose now so I tried disabling it for now