a

    Alex Bieliaiev

    1 year ago
    Hey guys. After
    7.0.0-alpha04
    to
    7.0.0-alpha06
    Android Gradle plugin migration I'm getting
    This version (1.0.0-alpha12) of the Compose Compiler requires Kotlin version 1.4.30 but you appear to be using Kotlin version 1.4.21 which is not known to be compatible.
    error. That is sort of expected, since I have a
    classpath("org.jetbrains.kotlin:kotlin-gradle-plugin:1.4.21")
    top-level dependency. Prior to the upgrade, however, I could explicitly specify
    kotlinCompilerVersion
    in the
    ComposeOptions
    section. As of now, this property seems to be deprecated. Do I have options other than complete project migration to Kotlin v1.4.30?
    d

    Denis

    1 year ago
    not using compose alpha12? Are there any reasons you can't migrate to 1.4.30?
    a

    Alex Bieliaiev

    1 year ago
    Thank you for your answer. There are basically two issues. First, my project is a KMM project, and I'm not yet sure that the shared part is ready for migration. Second, it's a KMM project, so I don't want single platform to push the entire project to update it's dependencies. But if that's the only option, then fine, since I don't want neither downgrade to alpha11, nor stick to a specific Android Studio/Gradle plugin version.
    d

    Denis

    1 year ago
    Probably a stupid question as I haven't looked into KMM. Isn't it possible to use different compiler versions for different platforms?
    a

    Alex Bieliaiev

    1 year ago
    Well, that's a good question.