Thread
#compose
    r

    redrield

    1 year ago
    implementation 'androidx.compose.ui:ui:1.0.0-alpha07'
        // Tooling support (Previews, etc.)
        implementation 'androidx.ui:ui-tooling:1.0.0-alpha06'
        // Foundation (Border, Background, Box, Image, Scroll, shapes, animations, etc.)
        implementation 'androidx.compose.foundation:foundation:1.0.0-alpha06'
        // Material Design
        implementation 'androidx.compose.material:material:1.0.0-alpha06'
        // Material design icons
        implementation 'androidx.compose.material:material-icons-core:1.0.0-alpha06'
        implementation 'androidx.compose.material:material-icons-extended:1.0.0-alpha06'
        // Integration with observables
        implementation 'androidx.compose.runtime:runtime-livedata:1.0.0-alpha06'
        implementation "androidx.navigation:navigation-compose:1.0.0-alpha02"
    compiler extension version 1.0.0-alpha06
    i

    Ian Lake

    1 year ago
    Note that you absolutely cannot mix alpha06s with alpha07s. You'll want to upgrade everything at the same time
    r

    redrield

    1 year ago
    studio has only notified me that ui has alpha07 available
    b

    Bradleycorn

    1 year ago
    I have updated everything to alpha07 (i use a variable to set the compose version), and Navigation to alpha02 … still having the issue. For me, when I stop using Navigation, I still get the same error, but it then shows as happening in MaterialTheme
    java.lang.NoSuchFieldError: No field Companion of type Landroidx/compose/runtime/SlotTable$Companion; in class Landroidx/compose/runtime/SlotTable; or its superclasses (declaration of 'androidx.compose.runtime.SlotTable' appears in /data/app/com.kysportsblogs.android-G1q_mSMF0wWD4JFpTJq_1Q==/base.apk)
            at androidx.compose.material.MaterialThemeKt.MaterialTheme(MaterialTheme.kt:112)
            at com.kysportsblogs.android.MainActivityKt.TestScreen(MainActivity.kt:32)
            at com.kysportsblogs.android.MainActivity$onCreate$1.invoke(MainActivity.kt:25)
            at com.kysportsblogs.android.MainActivity$onCreate$1.invoke(Unknown Source:10)
    OK, I’ve got mine working again with Material (not sure what I did other than:1. switch everything back to alpha06 2. sync 3. switch everything back to alpha07 4. sync Now trying to add navigation alpha02 back in.
    Annnnd … it seems I’m back up and running!
    So, it seems really odd to me that both myself and @redrield (working on entirely separate projects and don’t know each other from Adam) started having this problem at what appears to be the same time last night. And then today after switching dependency versions back and forth and resyncing, it seems to have gone away. Is it possible that one of the Compose (or Navigation) libs was messed up in the google repo last night (like an alpha6 binary file was in the repo tagged as alpha7) or something like that? That would certainly explain why we both started having problems at the same time, and why a simple resync would get it working again …