Random q: UI Components, Widgets, Views Is there a...
# compose
v
Random q: UI Components, Widgets, Views Is there anything on the list or elsewhere that you’ll use interchangeably with “Composable function”? I personally like “UI Component” when I’m speaking about a Composable function but wondering what this group thinks.
z
I’ve been having this discussion internally this week as well. Lots of confusion about the term “composable view”, since people think Compose actually uses Android views under the hood. I’m also on team “component” atm.
v
haha then I’m in the right company 👋🏼 🎉
r
@Leland Richardson [G] can share what our recommendations are
l
i think the two terms that we seem to have the most consensus around internally are “composable” and “component”
🙌🏼 4
we are trying to establish a “vocabulary” document that covers some other nuance
👏🏼 10
like “element” meaning the thing that is emitted from composition and has a size, draw, participates in layout, etc.
a
I separate my components like
MainActivityComponents
which contains the
@Composable
functions. There’s also
MainActivityComponent
which is actually a Dagger component though, so that’s a point of confusion. I’d get rid of that after migrating to hilt though, but there would still be the Hilt
ActivityComponent
etc. My own definition right now is that Compose Components are
@Composable
functions, so I refer to
Text()
as the Text component. For example.
Also, Design Systems typically refer to it as Components as well. So probably it should be Dagger that should rename their Components 😅
k
I really like the term component, because widget is like to be see in home page
r
Those are technically called app widgets
k
Ohh yes, thank you, I forgot the word