Thread
#compose
    henrikhorbovyi

    henrikhorbovyi

    2 years ago
    ?
    l

    Louis Pullen-Freilich [G]

    2 years ago
    I think you need to set a compiler flag, in your
    build.gradle
    :
    tasks.withType(org.jetbrains.kotlin.gradle.tasks.KotlinCompile).all {
            kotlinOptions {
                freeCompilerArgs += '-XXLanguage:+NonParenthesizedAnnotationsOnFunctionalTypes'
            }
        }
    henrikhorbovyi

    henrikhorbovyi

    2 years ago
    Yeah... It worked \o/ Thanks
    v

    Vinay Gaba

    2 years ago
    This is related to a kotlin bug that is fixed in
    Kotlin 1.4
    Afaik, Compose doesn’t work with Kotlin 1.4 yet so you need to use that compiler flag shared above. This should change soon though.
    r

    romainguy

    2 years ago
    Yes this is only temporary
    henrikhorbovyi

    henrikhorbovyi

    2 years ago
    @Vinay Gaba thanks for the details 🙌